Plugins in Sametime-Client von Notes 8 installieren

by Michael Urspringer - 26.06.2007

Ich habe einige Plugins die ich gerne auch mit dem eingebauten Sametime-Client im Notes 8 nutzen möchte. Leider sind dort standardmäßig die entsprechenden Menüpunkte nicht vorhanden um externe Datenquellen für Plugins hinzuzufügen.

Durch Hinzufügen der Zeile

com.ibm.notes.branding/enable.update.ui=true

in der Datei

…\notes\framework\rcp\plugin_customization.ini

und anschließendem Neustart ist dieses “Problem” behoben.

Man kann nun über den Menüpunkt “File -> Application -> Install” den aus dem Sametime 7.5.1-Client gewohnten Dialog aufrufen um externe Plugins hinzuzufügen.

Allerdings funktionieren leider nicht alle Plugins einwandfrei. Insbesondere die, die sich in der Sidebar einnisten wollen, funktionieren nicht.

Aber immerhin konnte ich damit einige Sachen zum Laufen bringen, die ich bsilang vermisst hatte.

[Danke an Martin B. für diesen Hinweis]

Update 19.07.2013:

You may also need to edit the following file in addition:

Go to <notesdata>\workspace\.metadata\.plugins\org.eclipse.core.runtime\.settings
Edit com.ibm.notes.branding.prefs file

Edit 2nd line
[Before] 
#Thu Sep 08 11:56:06 PDT 2011
enable.update.ui=false 
eclipse.preferences.version=1

[After] 
#Thu Sep 08 11:56:06 PDT 2011
enable.update.ui=true
eclipse.preferences.version=1

Tagged with:  

5 Responses to Plugins in Sametime-Client von Notes 8 installieren

  1. Hi Michael, ein kleiner Type am Ende “bsilang” und ein Link auf eine Installationsquelle für Plug-ins suche ich noch ;-), Gruesse, Florian

  2. jv [Besucher] says:

    Hallo Florian,
    Plugins zum Downloaden für Eclipse findest du zb auf http://www.jeffgilfelt.com!
    Jeff bietet auf seiner Seite drei Plugins zum Download (auch als src) an, welche einen sehr guten Eindruck vermitteln. Information zu Eclipse und Java-Plugin-Entwicklung findest du bei IBM. Such’ mal nach Lotus Expeditor Toolkit in Verbindung mit Eclipse und Lotus Notes 8.x.
    Lg

  3. Horst-Dieter Lange says:

    Hallo,

    so wie es aussieht funktioniert das nicht mehr in LN8.5.1. Gibt es da eine Alternative?
    Grüße

  4. Cali says:

    Thank you – this has been driving me mad – I needed to edit the notes branding prefs file for mine to work (Notes 9)

  5. […] Install”  in the menu of the Notes client although you already followed the instructions in this article, then try to set the value “enable.update.ui=true” in the […]

Leave a Reply

© 2000-2015 Michael Urspringer